Results 1 to 5 of 5

Thread: 1971 superglide,dies when decelerating

  1. #1
    Join Date
    Mar 2011
    Location
    Bethlehem PA
    Posts
    7

    Default 1971 superglide,dies when decelerating

    Bike runs fine,except when im downshifting to 2nd it just dies. I turn ingnition off and then back on. one kick,fires right up.idles great. next stopsign it dies. ran find before any ideas?

  2. #2
    Join Date
    Feb 2011
    Location
    Sunrise FL
    Posts
    5

    Default

    I would check the points and replace the condensor also check the advance unit they loosen up and do strang e things. The advance unit weights wear on the pins or the springs break. Good luck Ric

  3. #3
    Join Date
    Jul 2010
    Location
    Tuscola,Texas
    Posts
    251

    Default

    Make sure the coil to points wire isn't being rubbed or pulled by the shift linkage. Could have a bare spot or break in it.

  4. #4
    Join Date
    Feb 2006
    Location
    N W Ohio, USA
    Posts
    580

    Default

    The ignition switch could do this also. They can be touchy if worn, or the wires are not right and tight.
    Mike

  5. #5
    Join Date
    Mar 2011
    Location
    Bethlehem PA
    Posts
    7

    Default

    you guys rock. took me right to the problem....sort of... after replacing the springs on the weights and points and condenser..still had intermittent fire... I used a test light to find that the dam connector on the wire to the points was wrong and not making contact.
    replaced it. She runs flawlessly. Thanks for the help Brad

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •