Results 1 to 3 of 3

Thread: Main Shaft Sprocket

  1. #1
    Join Date
    Jan 2008
    Location
    PA
    Posts
    128

    Question Main Shaft Sprocket

    Hi all,

    I am confused. I have a 64 FLH. I went to change the trany main shaft oil seal today and found something odd, or at least I think its odd. When I pulled the clutch hub I found that the oil deflector and the lockwasher was missing from behind the rear chain sprocket hex nut. I was suprised to find the parts at my local HD dealer. When I went to reassemble I did not have enough threads sticking out on the main shaft once I put the deflector and lock washer on to start the hex nut. I figured the lock washer was far more important then the deflector so I tried with the lock washer and hex nut only. I still only had enough thread on the mainshaft to get one or two threads on the hex nut. I can see why the deflector and lock washer were not put on by some previous owner. I do not want to reassemble without at least having the lock washer in place behind the hex nuts and a full set of threads engaged. Does anyone have any ideas? Could it be that some one had done work in the trany and has shims in the wrong place, or too many shims that will not allow the mainshaft to extend out far enough? I do not have the skills for internal tranny work so I am hoping that this is not the case.

    Thanks for any info.

  2. #2
    Join Date
    Aug 2004
    Location
    Beautiful Northern New Mexico
    Posts
    2,794

    Default

    If all the components do not fit on your main drive gear assembly there is a definite problem. Is the sprocket seated all the way on the shaft? You also may have pushed the main drive gear into the gearbox housing. There is nothing that holds it in place except the nut/deflector/lock assembly. Is the L shaped key in place behind the sprocket that drives the oil seal sleeve? If it jumped out of its notch it could possibly hold things apart. Slide your sprocket off and pull on the main drive gear to make sure it is all the way towards you. Measure the amount exposed beyond the seal sleeve. Stack up the sprocket, slinger, lock, and nut. Measure the combined width. the numbers should be the same or close to it. Is the sprocket correctly mounted with the relief towards the gearbox? If the main drive gear was pushed too far into the gearbox one of the rollers could have fallen out and be stuck between the gear and the race. If that is the problem with the seal removed and the seal sleeve off the gear it can be replaced from the outside. If a roller fell off on the inner side there is only one way to fix it, disassemble the gearbox. Hopefully neither scenario occurred. The mainshaft has nothing to do with this problem. The longer mainshafts are in electric start gearboxes. It is all in the assembly of the main drive gear and related parts. Do you have a manual? Good luck
    Robbie
    Robbie Knight Amca #2736

  3. #3
    Join Date
    Jan 2008
    Location
    PA
    Posts
    128

    Unhappy Main shaft sprocket

    I found my problem. The last couple of threads on the end of the main gear were sheared off. the sprocket must have came loose on the previous owner at some point.

    Thanks for the feed back.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •