Results 1 to 6 of 6

Thread: panhead oil pressure

  1. #1
    bhuffman Guest

    Default panhead oil pressure

    I have a 49 pan completely rebuilt from the bottom up. Starts good, runs great. I am running 50 wt to break it in. After the oil gets hot the oil pressure light will not go out until maybe 1500 rpm. The books I have say nothing about adjusting the check valve in the pump other than the initial setting. Any ideas???

  2. #2
    Paps Guest

    Default

    Is it a repop oil pressure sending unit ?? If it is....get an nos or used oem one. Paps

  3. #3
    flthead Guest

    Default

    my '50 lite comes on ,only cause the aftermarket switch !

  4. #4
    bhuffman Guest

    Default

    The switch is a repo-- I will try an oem
    Thanks

  5. #5
    Paps Guest

    Default

    9 times out of 10 this has been the case when the light stays on. Not always the case, just most of the time it is. Just this year alone, a dozen or so folks asked me the same question. They changed the unit and their lights went out. Before trying to find out if there may be another cause, many of them were ready to replace or rebuild their pumps, etc. Trying an authentic unit is the cheapest route to go for a start if you have a known repop already instaled in your engine. Paps

  6. #6
    partshunt Guest

    Default

    I dont know what the pressure switch "break" point is, probably 3-5 lbs. First thing I'd do is install a pressure guage and run it up to temp and see if the pressure is 3-5 lbs or zero. If zreo at idle and especially a bit above, there are other problems. You need some pressure to "break open" that switch hey??...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •