PDA

View Full Version : linkert m51 carb problems



Erdos
06-29-2001, 03:04 PM
I am having a heck of a time with my float in my m-51 linkert carb. I have worked hours on this and can't seem to make any progress. I would really appriciate any sugestions that might help.

What I have done so far.
1)Followed all directions on how to align the float.
2)Tested to see if the float was good, it is.
3)the valve seats well.

What happens is when I put the bowl on the float gets hung up on the main jet housing and no matter were I place it, it still happens. Every time I think I have it free as soon as I install it it sticks and gas is everywere. I have even tried 2 bowl gaskets to see if that helps.

I am pulling out my hair!!!!!! Please help.
Or i'll sell you a 45wl CHEAP. just kidding.

Buster
07-03-2001, 05:54 PM
The float is supposed to be installed 1/16" off center to not hit the main jet. As far as the brass float, I would weight it to see how much more it weights than the stock float. I fooled with a brass float for several months in both a M51 and M88 on my servi and never could set it low enough for the motor to not to run too rich and foul plugs. Some brass floats are not usable due to weight.

JEM
04-02-2002, 11:10 PM
I have had similar problems with my 45", but with a cork float. I have never converted to brass yet. Certainly the adjustments of the foat are critical, but also the position of the float bowl is part of being successful. It does not sit square (at 90 degrees) to the body of the carb, but rather pivoted so that the needle & seat are close to the high speed needle.